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Update User Profile

To update your User Profile, navigate to Profile > Profile Details > Choose File > Upload
Then, Save.

Profile

Hello Bernard

Bernard
bernard@gmail.com We're glad to have you on board

Click to view
Profile Details.

Dashboard

career o Navigate to [ B Profile Details
Profile.
Course Catalogus .
Upload Picture

B Login & Security
choose Fil To upload Profile Picture, click
i ploa to Choose File & Upload it.

Please enter your profile details

Profile
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Edit Password

To update your User Profile, navigate to Profile > Login & Security > Edit Password
Edit Password details.
Then, Proceed.

[[ career Journal

; Click to view . .
Profile Details
B Login & Security. Logm & Secu"ty

Password Email
P R Click to Edit bernard@gmail.com

&= Course Catalogue
o
~A

Nagrig;::_ to [ B Login & Security

Password.

. Bernard
bernard@gmail.com B Profile Details Edit Password

Enter your new password and you're all set. Please use a new and unique password.

OF Dashboard B Login & Security > Current Password *

[ career Joural &  Enter your current password ®
Course Catalogue New Password *
Profile & Enter your new password ®

Confirm New Password *

& Re-enter your new password @

CE® Organisation Profile Proceed
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Career Journal

Step 1: Experience

To add Experience, navigate to Career Journal > Experience

Select No, | will fill the form manually.

Enter information for My Experience.

Select 1 or more reference job roles to add Key Task / Skills & Competencies relevant to your job position.
Then, Save.

Click to Add Experience or Add Certificate to add another profile.

Career Journal > Experiences

. Sermars My Experiences and Certificates

bernard@gmail.com

OF Dashboard

|:E| Career Journal
Navigate to
ESf Experience Experience.
[ skills import your experiences and skills on LinkedIn or copy

from another account.
A Career Path
We'll be adding the imported data to your profile.

. ) ] Select option to fill

OF Generatecv

B course Catalogue
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Career Journal > Experiences

My Experiences and Certificates

Bernard

bernard@gmail.com

OF Dashboard Enter

My Experience

information.

[F career Journal Job Title *

E B Manager, Talent Management

Company Name * Location *
[ skills pany

DNA Capitals Pte Ltd Singapore x Vv

A Career Path

Company Logo (square image)
£
SAP|

,Q\ Profile Select file

uﬂ
O Generate CV T DNAC logo.png

E Course Catalogue & UPG, GIF or PNG. Max Size of 800KB

Check if this is your

current position. | am currently working here.

| Logout
::l s Start Date *

Jan 2022




Add Key Task / Skills &
Competencies relevant
to your job

bernard@gmail.com

OF Dashboard

[F] career Journal

B«
|jj] skills

4 Career Path
Click to add relevant

B8 Gen pre-populated Key Task.

&= Course Catalogue

. e
bernard@amail com

Click to add relevant

pre-populated Acquired Technical

Skills & Competencies (TSC).

[ career Journal

=

CAREERTAGC

Key Task / Skills & Competencies ]

You may select T or more reference job roles 1o add key tasks and acquired skills & competencies relevant to your job position.

Reference Job Role
Select Reference Job Role.
Manager, Talent Management | Talent Management

Key Tasks

Optional: Click on the dropdown

icon to add your own Key Task.

Adapt and tailor different styles and preferences when communicating to different audiences or stakeholder groups. ¥

Key Task added from

Adopt a service-oriented mindset and people-centricity in dealing with workforce and business stakeholders. %

Suggested Key Task.

Suggested Key Task(s) A~

Administer redundancy or individual severance programmes in accordance with labour and employment laws and regulations, and industry practices. +

Advise on labour policies, employment legislation and their applications 1o senior business leaders to facilitate their understanding of compliance +
requirements.

Acquired Technical Skills & Competencies (TSC) Acquired Critical Core Skills (CCS)

Suggested Skill(s) A Suggested Skill(s) A

Business Acumen (for HR) + Collaboration + Communication <+ Decision Making +

Business Performance Program Management + Developing People + Problem Solving +

Career Coaching + Career Framework Design =+

Click to add relevant
pre-populated Acquired
Critical Core Skills (CCS).

Competency Framework Development + more...
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Optional: Add Key Key Accomplishment(s) ]
Accomplishment.

OF Genera
B course Catalogue
o
A

Profile £

5] Logout Save Click to Save.

My Experiences and Certificate To add another

Experience or Certificate.

bernard@gmail.com

tricia.lim.be@gmail.com

OF Dashboard Experiences

[ career Journal

e Manager, Talent Management To edit or delete y
= ol January 2022 - Present Experience.
Iﬁl Skills Executive, Employee Experience and Relations T
January 2019 - December 2021

A Career Path

OF Generate CV 1102 of 2 items

& Course Catalogue Certificates

,0\ Profile ) .
IHRP Certified Professional (IHRP-CP) T
May 2021 - August 2021
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Enter
information.

My Certificate

Certificate Type *

Bemard Educational Certification o Professional / Training Certification

bernard@gmail.com
Certification/Course Title *

IHRP Certified Professional (IHRP-CP)

OF Dashboard

] Organisation / Issued by * Location *
EE' Career Journal Institute for Human Resource Professionals Select... ~
E T Start Date * End Date *
May 2021 Aug 2021
() skils
Level Major / Specialisation
A  Career Path .
- Intermediate Human Resource

Click to add relevant Technical Skills & Competencies (TSC)where applicable

pre-populated Technical Skills [ v ]
& Competencies (TSC).

A Career Path Human Resource Policies and Legislation Framework Management | Human Resource ¥  Human Resource Practices Implementation | Human Resource %

. Critical Core Skills (CCS)wh licabi
Click to add relevant (CCS)where spplicable

pre-populated Critical [ v ]
Core Skills (CCS).

Problem Solving ®  Transdisciplinary Thinking %  Developing People %

\ Save Click to Save.
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Step 2: Skills

To add Technical Skills & Competencies, navigate to Skills > Technical Competency

Save after tagging each Technical Skills & Competencies (TSC) to Experience and/or Certificate.
Click on Critical Core Skills to add relevant skills.

Technical Skills & Competencies Sl

Bernard
bernard@gmail.com

OF Dashboard

Click on the Technical Skills &
Competencies (TSC) to view

pre-selected proficiency level.
B v wiattagement | Human Resource | New | (X)

Business Acumen (for HR) | Human Resource ® n Resource | New (2)

Business Performance Program Management | Human Resource

[F career Journal .
Diversity and Inclusion Management | Human Resource | New | (X)

B9 Experience —
sl adbegislation Framework Management | Human Resource | New | (X)
() skils Navigate to
Career Journal > Skills >
@ Technica Technical Competency.
S BOEie

ectives and desired outcomes with human resource (HR) decisions, operations and activities to drive HR initiatives from a business angle

I critical Core Skills

Click to select relevant Drive business agenda for human Design human resource (HR) plans and ~ Influence business strategies by
A Career Path proficiency level. resource (HR) plans and programmes initiatives in alignment with providing inputs related to workforce
- organisation's strategic direction agenda
02 ~onornio oV
Tagged vaUired Technical Experiences Certificates
Skills & Competencies (TSC)
to Experience and/or Select... v Select... v

Certificate. Then, Save.

Manager, Talent o IHI%P Certified Professional (IHRP- o



Bermnard

bernard@gmail.com

PE Nachhnard
Navigate to
Career Journal > Skills >
Critical Core Skills.
E°] Experience

(1) skills

() Technical Competency

A Career Path

02~ 4o AT
= Tagged acquired Critical
¢ Core Skills (CCS) to
. Experience and/or
Certificate. Then, Save.

Career Journal > Skills > Critical Core Skills

Critical Core Skills

Click on the Critical Core Skills
(CCS) to view pre-selected
proficiency level.

| Collaboration ()

Problem Solving | New | (X)

g | New (\g)

Collaboration

Manage relationships and work collaboratively and effectively with others to achieve goals

CAREERTAGC

Optional: To add

another Skill.

Developing People | New (g)

Wyt Click to select relevant

SRR proficiency level.
managing i

support to others to achieve goals

and external stakeholders to create synergies in
working towards shared goals

Build relationships and work effectively with internal

Establish team effectiveness and manage
partnerships to create a cooperative working
environment which enables the achievement of goals

Experiences Certificates

Select... v Select...

Manager, Talent

o Executive, Employee Experience and
Management

Relations e
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Step 3: Career Path

Navigate to Career Journal > Career Path

Select a Profile (Job Role created by Organisation)

Click to View Profile.

Click Compare to view Skills to attain and Skills acquired.

Career Journal > Career Path

— Career Path

bernard@gmail.com

Click to View Profile & then click on Compare to

Sl el view Skills to attain and Skills acquired.

dropdown menu

Select a Profile

OF Dashboard Select... View Profile

|:E| Career Journal Q [search..
Job Role created

Manager, Talent Management & Employee Engagement | Human Resource | People Development by Organisation

ES] Experience

() skills
ot Navigate to
er Path
Career Journal > Career Path.
[ career Journal Manager, Talent Management & Employee Engagement
E Experience The Manager, Talent Management develops and implements talent management programmes to groom talent in the organisation for the fulfilment of current and future business
requirements. He/She designs career pathways to generate awareness on career progression opportunities in the organisation and guides line managers on employee career
[m Skills development policies and programmes. He manages high-potential talent and succession planning programmes, to develop a strong pipeline for critical roles in the organisation and

ensure business success and continuity. He is also responsible for implementing retirement and exit policies and programmes in the organisation, managing redundancies and guiding
. other colleagues in managing staff exits. In addition, he is accountable for managing team operations and performance, and integrating Skill Frameworks into the talent management
(@ Technical Competency programmes and initiatives under his team's purview.

E' Critical Core Skills The Manager, Talent Management possesses strong people-orientation; he is an excellent communicator who is diplomatic and engaging when interacting with stakeholders at the
workplace. He critically analyses complex issues and is able to arrive at robust decisions and solutions.

A Ca ath

Critical Work Functions & Key tasks i
OF Generatecv

Analytics and Insights, CP v
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Click to view tab: Technical Skills & Competencies (TSC) to attain

Career Path

o. of Technical Skills & q
Competencies (TSC) to TSC to attain 21 CCS to attain 7 TSC Achieved 5 CCS achieved 0

be attained.

r Romard Manager, Talent Management & Employee Engagement (, 0)

EIE Dachhaard Data Collection and Preparation _ Business Performance Program Management _: :I Employee Relationship Management I-: :I
Click to view the skill
[ gap(s) between current

level & required level. : -
o] Experience | Stakeholder Engagement and Management [‘I Human Resource Analytics and Insights {-7 | Organisational Change Management [I

[ Employee Communication Management [ ' Operational Excellence L-:\ Health and Wellness Programme Management [ )

ﬁj] Skills Technology Integration f.:l Data Governance l[ | Project Management [I Human Resource Strategy Formulation II |

@ Technical Competency Human Resource Service Quality Management I :\ Human Resource Digitalisation [I | Organisational Culture Development I \
Igl Critical Core Skills Organisational Diagnosis [l '| HR Risk Management fl __I Leadership Development rl __\ Human Resource Advisory ! |
4 Path Financial Acumen I :\
= Proficiency Level
o8 G s l__| Required Level
aO Generate CV Employee Communication Management a i Industry: Human Resource
e 2 [ Your Current Level reqUIrEd' Y
&3 Course Cataloaue Formulate overall employee communication strategies and facilitate conversations to e ective and timely dissemination of pertinent information to employees
] Logout
Disseminate information to employees Develop employee communication plans, facilitating Formulate employee communication strategies for the

conversations with and among employees organisation

-
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Click to view tab: Critical Core Skills (CCS) to attain

Bermnard

bernard@gmail.com

OF Dashboard

L Click to view the skill

gap(s) between current
level & required level.

(i) skills

() Technical Competency
3 critical Core Skills
ath

OF Generate CV

Me Talent > Career Path > Compare

Career P
(CCS) to be attained.

Select Job Profile

Manager, Talent Manage & Employee Engagement (, 0)

CCS to attain 7

Building Inclusivity | ' Creative Thinking -:\

Communication - Problem Solving -
T o Required Level
Building Inclusivity Fil &
Your Current Level

Collaborate with stakeholders from different backgrounds or with different alf
learning ability, education, socio-economic status and political belief, to understand the i

TSC to attain 21

TSC Achieved 5 CCS achieved 0

Decision Making -:I Developing People -:\ Collaboration -

Proficiency Level
required.

sions such as race, ethnicity, religion, gender orientation, age, physical and
of diverse groups and build an inclusive work environment

Demonstrate sensitivity to the differences in diversity Manage relationships across diverse groups within the Oversee the develop and implement processes and
dimensions and perspectives organisation practices which build an inclusive work environment
and enable diverse groups to work effectively together
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Click to view tab: Technical Skills & Competencies (TSC) achieved

Me Talent » Career Path > Compare

Bemard Career Path No. of Technical Skills &

A —p— Competencies (TSC) achieved.

Manager, Talent Management & Employee Wgfigement (, 0)

OF Dashboard TSC to attain 21 CCS to attain 7 cCS achieved 0
L Click to view the sil .
gap(s) between current Diversity and Inclusion Management | . Conduct and Behaviour Management \-: |

level & required level.

() skills

Human Resource Policies and Legislation Framework Management \.: | Human Resource Practices Implementation \.: |

Business Acumen (for HR) \.: |

- Proficiency Level
- ; . | | Required Level .
Diversity and Inclusion Management requ”-ed_ Industry: Human Resource

Your Current Level

@ Technical Competency

3 critical Core Skills

Develop strategies and programmes to create an diverse and inclusive workplace where igd al differences are accepted and respected
E Generate CV Implement diversity and inclusion programmes to Translate diversity strategies into diversity and inclusion Develop diversity sirategies that promote a diverse and
enhance workplace diversity and promote an inclusive programmes at the workplace inclusive environment and are aligned to organisational
—_ workplace objectives, vision, mission and values
= Course Catalomne
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Click to view tab: Critical Core Skills (CCS) achieved

pemard Career Path

No. of Critical Core Skills
(CCS) to be achieved.

bernard@gmail.com

Manager, Talent Management & Employee E
Click to view the skill
gap(s) between current TSC to attain 21 CCS to attain 6 TSC Achieved 5 CCS achieved 1

level & required level.
L[j Career Journal

E9] Experience

Problem Solvin P Required Level
[f_tl Skills 9 - Your Current Level

Generate effective and efficient solutions to solve problems and capitalise on new opportunities

Proficiency Level
1 required.

@ Technical Competency

|§| Critical Core Skills Identify problems and implement guidelines and Determine underlying causes of problems and Anticipate potential problems to drive a culture of
procedures to solve problems and test solutions collaborate with other stakeholders to implement and continuous improvement which seeks to turn problems
evaluate solutions into opportunities across the organisation
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